No Sound for Ubuntu

One of the problems after installing Ubuntu was the lack of sound. I found that patching alsa fixed it. Just follow the instructions by nicfagn posted here. This didn’t make the headphones work and it wouldn’t mute completely, but it’s all I need for my purposes right now and since Hardy Heron in due out in a few month. Maybe I’ll try to figure out the other issues then.

Dual boot Ubuntu on an Aluminum iMac

I finally got around to installing Ubuntu on my system. It wasn’t exactly smooth going, but I’ll detail what I think I did here. It worked after I set the partition map to use Master Boot Record, but I may have done something else on a previous attempt.

1) Partition your system. I ended up wiping my drive and restoring with Time Machine, but that could possibly be avoided using Boot Camp or gParted. Anyhow, I booted from the Leopard install CD and used Disk Utility to do the partitioning. Here is where I set the partition map to “Master Boot Record”. I left enough “Free space” for my Ubuntu install and some for swap. (I used 2 GB) The rest I left for Leopard and restored it with Time Machine.

2) Install Ubuntu. Boot from the Ubuntu LiveCD and double-click the install icon on the desktop. When it asks you where to install choose manual. Then set up your swap area in the free space and the rest of it for your Ubuntu HD. Be sure to specify the mount point of / and I used ext3 as the format.

3) Reboot and hold down the option key and you should see second option in your boot menu. I choose to install rEFIt on my Leopard drive so I don’t have to hold the option key. I automatically get options and it looks much nicer.

That’s the basics of it. I had some problems with Ubuntu not getting the screen resolution right and no sound, but I’ll work on those later.